Symptom:
When enabled, the SAP SIOS HA Cluster Connector fails to update the state of the SAP resource in LifeKeeper after the protected SAP instance is started or stopped outside of LifeKeeper (e.g., using sapcontrol, SAP Management Console, etc.). Errors similar to the following appear in the sapstartsrv.log file for the protected SAP instance when SAP HA Library debug logging is enabled (i.e., /service/halib_debug_level >= 1):
SAP HA Trace: Using tmp file /tmp/sapha-tmp-KKGWWV
SAP HA Trace: Fire system command /opt/LifeKeeper/lkadm/subsys/appsuite/sap/bin/sap_sios_cluster_connector /opt/LifeKeeper/lkadm/subsys/appsuite/sap/bin/sap_sios_cluster_connector lsr --out /tmp/sapha-tmp-KKGWWV --sid SPS --ino 10
SAP HA Trace: ClusterFileBuffer: <>SAP HA Trace: parseClusterFile Line: 0
SAP HA Trace: searchClusterFile: SPS:10 NOT found
SAP HA Trace: searchClusterFile: rc = 1
Cause:
Due to a change made in the SAP HA Script Connector Library in April 2021 (see SAP Note 3018407), the SAP SIOS HA Cluster Connector is unable to successfully return information about the state of cluster resources to the HA Script Connector Library on servers running LifeKeeper v9.6.0 or earlier and the following affected SAP kernel versions:
SAP Kernel | Patch Level |
---|---|
SAP Kernel 7.22 64-bit | PL >= 1021 |
SAP Kernel 7.22 64-bit unicode | PL >= 1021 |
SAP Kernel 7.22 EXT 64-bit | PL >= 1021 |
SAP Kernel 7.22 EXT 64-bit unicode | PL >= 1021 |
SAP Kernel 7.22 EX2 64-bit | PL >= 1021 |
SAP Kernel 7.22 EX2 64-bit unicode | PL >= 1021 |
SAP Kernel 7.49 64-bit | PL >= 942 |
SAP Kernel 7.49 64-bit unicode | PL >= 942 |
SAP Kernel 7.53 64-bit | PL >= 810 |
SAP Kernel 7.53 64-bit unicode | PL >= 810 |
SAP Kernel 7.77 64-bit unicode | PL >= 324 |
SAP Kernel 7.81 64-bit unicode | PL >= 110 |
SAP Kernel 7.85 64-bit unicode | All |
Action:
On an affected server, the protected SAP instance should be started or stopped only through LifeKeeper (e.g., using the LifeKeeper GUI or LifeKeeper Command Line Interface). Otherwise, when LifeKeeper detects that the protected instance has been stopped it will take action to either restart the instance locally or initiate a resource failover to the standby server.
The issue can be resolved by either:
(i) Upgrading to a version of LifeKeeper later than v9.6.0, or
(ii) Installing the hotfix for LifeKeeper v9.5.2 or v9.6.0 located here:
http://ftp.us.sios.com/pickup/SAP-rpm-PL-13003-9.6.0
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