Version 9.4.0

Important!!

Read This Document Before Attempting To Install Or Use This Product!
This document contains last minute information that must be considered before, during and after installation.

Introduction

This release notes document is written for the person who installs, configures and/or administers the SIOS Protection Suite (SPS) for Linux product. The document contains important information not detailed in the formal LifeKeeper and DataKeeper documentation sets such as package versions and last-minute changes to instructions and procedures as well as a link to the Troubleshooting sections for product restrictions and troubleshooting hints and tips that were discovered through final product testing. It is important that you review this document before installing and configuring SPS software.

SIOS Product Descriptions

LifeKeeper for Linux

The LifeKeeper product includes fault detection and recovery software that provides high availability for file systems, network addresses, applications and processes running on Linux. LifeKeeper supports the configuration and switchover of a given application across multiple servers. The servers on which the application is configured are assigned priorities to determine the sequence in which the application will move from server to server in the event of multiple failures.

LifeKeeper for Linux provides switchover protection for a range of system resources. Automatic recovery is supported for the following resource types:

  • Processes and Applications
  • Shared Storage Devices
  • File Systems (ext3, ext4, vxfs, xfs and nfs) Note: btrfs is not currently supported by the SIOS Protection Suite for Linux. For the detailed information see Troubleshooting > Known Issues and Restrictions.
  • Communication Resources (TCP/IP)

DataKeeper for Linux

The SIOS DataKeeper product:

  • Provides volume-based synchronous and asynchronous data replication.
  • Integrates into the LifeKeeper Graphical User Interface for administration and monitoring.
  • Automatically resynchronizes data between source and target servers at system recovery.
  • Monitors the health of underlying system components and performs local recovery in the event of failure.
  • Allows manual resource switchovers and failovers of mirrored volumes.
  • Can be easily upgraded to provide high availability clustering and automatic failover and recovery using a license key to enable new functionality.

SPS Components

SPS Core

SPS for Linux is bundled for, and only runs on, 64-bit systems (AMD64 and EM64T systems).

The SPS Core Package Cluster includes the following installable packages:

Package
Package Name
Description
LifeKeeper Core steeleye-lk-9.4.0-6863.x86_64.rpm The LifeKeeper package provides recovery software for failures associated with core system components such as memory, CPUs, the operating system, the SCSI disk subsystem and file systems.
DataKeeper Core steeleye-lkDR-9.4.0-6863.noarch.rpm The DataKeeper package provides data replication (synchronous or asynchronous mirrors with intent logging).
LifeKeeper GUI steeleye-lkGUI-9.4.0-6863.x86_64.rpm The LifeKeeper GUI package provides a graphical user interface for LifeKeeper and DataKeeper administration and status monitoring.
SPS IP Recovery Kit steeleye-lkIP-9.4.0-6863.noarch.rpm The SPS IP Recovery Kit provides recovery software for automatic switchover of IP addresses.
SPS Raw I/O Recovery Kit steeleye-lkRAW-9.4.0-6863.noarch.rpm The SPS Raw I/O Recovery Kit provides support for applications that use raw i/o to bypass kernel buffering.
LifeKeeper Man Pages steeleye-lkMAN-9.4.0-6863.noarch.rpm The LifeKeeper Man Page package provides reference manual pages for the SPS product.

SPS Optional Recovery Software

The following optional software provides resource definition and recovery software for the application versions listed:

Package
Package Name
Description
SPS Apache Web Server Recovery Kit steeleye-lkAPA-9.4.0-6863.noarch.rpm The SPS for Linux Apache Web Server Recovery Kit provides fault resilience for Apache Web Server software in an SPS environment.
SPS SAP Recovery Kit steeleye-lkSAP-9.4.0-6863.noarch.rpm The SPS for Linux SAP Recovery Kit provides a mechanism to recover SAP NetWeaver from a failed primary server onto a backup server in an SPS environment working in conjunction with other SPS Recovery Kits to provide comprehensive failover protection.
SPS SAP MaxDB Recovery Kit steeleye-lkSAPDB-9.4.0-6863.noarch.rpm The SAP MaxDB Recovery Kit provides fault resilient protection for SAP MaxDB databases in an SPS for Linux environment.
SPS DB2 Recovery Kit steeleye-lkDB2-9.4.0-6863.noarch.rpm The SPS for Linux DB2 Recovery Kit provides fault resilient protection for DB2 database instances. SPS together with the DB2 Universal Database product family afford increased availability to DB2 operating environments by effectively recovering database server failures without significant down-time or human intervention.
SPS Oracle Recovery Kit steeleye-lkORA-9.4.0-6863.noarch.rpm The SPS for Linux Oracle Recovery Kit provides fault resilience for Oracle software in an SPS environment furnishing a mechanism to tie the data integrity of Oracle databases to the increased availability provided by SPS.
SPS MySQL Recovery Kit steeleye-lkSQL-9.4.0-6863.noarch.rpm The SPS for Linux MySQL Recovery Kit provides an easy way to add SPS fault‑resilient protection for MySQL resources and databases enabling a failure on the primary database server to be recovered on a designated backup server without significant lost time or human intervention.
SPS PostgreSQL Recovery Kit steeleye-lkPGSQL-9.4.0-6863.noarch.rpm The SPS for Linux PostgreSQL Recovery Kit is an SQL compliant, object-relational database management system (ORDBMS) based on POSTGRES providing a mechanism for protecting PostgreSQL instances within SPS.
SPS Sybase ASE Recovery Kit steeleye-lkSYBASE-9.4.0-6863.noarch.rpm The SPS for Linux Sybase ASE Recovery Kit provides SPS resource protection for the Sybase ASE components Adaptive Server, Monitor Server, and Backup Server.
SPS Postfix Recovery Kit steeleye-lkPOSTFIX-9.4.0-6863.noarch.rpm The SPS for Linux Postfix Recovery Kit provides a mechanism to recover Postfix from a failed primary server to a backup server in an SPS environment.
SPS Samba Recovery Kit steeleye-lkSMB-9.4.0-6863.noarch.rpm The SPS for Linux Samba Recovery Kit provides fault resilient protection for Samba file and print shares on a Linux server existing in a heterogeneous network enabling a failure on the primary Samba server to be recovered on a designated backup server without significant lost time or human intervention.
SPS NFS Server Recovery Kit steeleye-lkNFS-9.4.0-6863.noarch.rpm The SPS for Linux NFS Server Recovery Kit provides fault resilience for Network File System (NFS) software in an SPS environment enabling a failure on the primary NFS server to be recovered on a designated backup server without significant lost time or human intervention.
SPS Network Attached Storage Recovery Kit steeleye-lkNAS-9.4.0-6863.noarch.rpm The SPS for Linux Network Attached Storage Recovery Kit provides fault resilience for Network File System (NFS) software in an SPS environment affording SPS users the opportunity to employ an exported NFS file system as the storage basis for SPS hierarchies.
SPS Logical Volume Manager (LVM) Recovery Kit steeleye-lkLVM-9.4.0-6863.noarch.rpm The SPS for Linux Logical Volume Manager (LVM) Recovery Kit provides logical volume support for other SPS recovery kits allowing SPS-protected applications to take advantage of the benefits offered by the Logical Volume Manager, including simplified storage management and the ability to dynamically re-size volumes as needs change.
SPS Software RAID (md) Recovery Kit steeleye-lkMD-9.4.0-6863.noarch.rpm The SPS for Linux Software RAID (md) Recovery Kit provides software RAID support for other SPS recovery kits allowing SPS-protected applications to take advantage of the benefits offered by software RAID, including lower cost data redundancy, data replication over a SAN and simplified storage management.
SPS PowerPath Recovery Kit steeleye-lkPPATH-9.4.0-6863.noarch.rpm The SPS PowerPath Recovery Kit protects applications that use EMC PowerPath multipath I/O devices.
SPS Device Mapper Multipath (DMMP) Recovery Kit steeleye-lkDMMP-9.4.0-6863.noarch.rpm The SPS Device Mapper Multipath (DMMP Recovery Kit) protects applications and file systems that use DMMP devices allowing SPS to operate with and protect these applications and file systems.
Hitachi Dynamic Link Manager Software (HDLM) Recovery Kit steeleye-lkHDLM-9.4.0-6863.noarch.rpm The Hitachi Dynamic Link Manager Software (HDLM) Recovery Kit protects applications that use Hitachi Dynamic Link Manager Software devices.
SPS NEC iStorage StoragePathSavior (NECSPS) Recovery Kit steeleye-lkSPS-9.4.0-6863.noarch.rpm The SPS NEC iStorage StoragePathSavior (NECSPS) Recovery Kit protects applications that use NEC iStorage StoragePathSavior v3.3 or later multipath I/O devices.
SIOS DataKeeper steeleye-lkDR-9.4.0-6863.noarch.rpm SIOS DataKeeper for Linux provides an integrated data mirroring capability for SPS environments enabling SPS resources to operate in shared and non-shared storage environments.
SPS WebSphere MQ Recovery Kit steeleye-lkMQS-9.4.0-6863.noarch.rpm The SPS for Linux WebSphere MQ Recovery Kit provides fault resilient protection for WebSphere MQ queue managers and queue manager storage locations enabling a failure on a primary WebSphere MQ server or queue manager to be recovered on the primary server or a designated backup server without significant lost time or human intervention.
Quorum/Witness Package steeleye-lkQWK-9.4.0-6863.noarch.rpm The SPS Quorum/Witness Package allows a node to get a “second opinion” on the status of a failing node acting as an intermediary to determine which servers are part of the cluster. When determining when to fail over, the Witness Server allows resources to be brought in service on a backup server only in cases where it verifies the primary server has failed and is no longer part of the cluster.
Quick Service Protection steeleye-lkQSP-9.4.0-6863.noarch.rpm SPS Quick Service Protection supplies functionality to easily protect OS services.
Recovery Kit for EC2 steeleye-lkECC-9.4.0-6863.noarch.rpm The Recovery Kit for EC2 provides a mechanism to recover an Elastic IP from a failed primary server to a backup server. It also provides a mechanism to enable the IP Recovery Kit to work in multiple availability zones.
Route53 Recovery Kit steeleye-lkROUTE53-9.4.0-6863.noarch.rpm Route53 Recovery Kit provides a mechanism for updating Amazon Route 53 DNS information corresponding to a virtual IP address and an actual IP address information of IP resources that are in dependency relation when switching to a failed primary server to a backup server.

New Features of SIOS Protection Suite for Linux Version 9

Product
Feature
New in Version 9.4.0
LifeKeeper Core Standby Node Health Check – allows the user to monitor CPU and memory utilization on the standby node and monitor the health of out-of-service (OSU) resources to detect errors on the standby node.
Oracle Linux 7 Unbreakable Enterprise Kernel Release 5 (UEK R5) is supported.

Red Hat Enterprise Linux 8 is supported.

Note: Upgrading from one kernel version to another major version such as from RHEL7 to RHEL8 is NOT supported. (i.e DataKeeper resource does NOT work when upgrading from RHEL7 to RHEL8.)

SAP SAP-certified support of SAP S/4HANA 1809 platform via SAP High Availability Clustering Certification S/4-HA-CLU-1.0
Support for Standalone Enqueue Server 2 (ENSAv2) and Enqueue Replication Server 2 (ERSv2)
SAP Resource UI Enhancements
Optimizations for the LifeKeeper SAP ERS Resource
MySQL MariaDB10.3 is suppoted.
DB2 DB2 11.5 is supported.
General maintenance Bug Fixes
New in Version 9.3.2
LifeKeeper Core

Red Hat Enterprise Linux 7.6 is supported.

Note: DataKeeper asynchronous mirrors are not supported because of a Linux kernel bug.

CentOS 7.6 is supported.

Note: DataKeeper asynchronous mirrors are not supported because of a Linux kernel bug.

Oracle Linux Version 7.6 is supported.

Note: DataKeeper asynchronous mirrors are not supported because of a Linux kernel bug.

Note: Unbreakable Enterprise Kernel Release 5 (UEK R5) is NOT supported. (i.e. DataKeeper resource does NOT work on UEK R5.)

Linux Enterprise Server 12 SP4 is supported.

SUSE Linux Enterprise Server 15 is supported.

Note: Upgrading from one kernel version to another major version such as from SLES 12 to SLES 15 is NOT supported. (i.e DataKeeper resource does NOT work when upgrading from SLES 12 to SLES 15.)

OpenJDK v10.0.2 is supported.

SIOS has tested OpenJDK v10.0.2 downloaded from https://jdk.java.net/10/ with SIOS Protection Suite for Linux (SPS-L) v9.4.0. OpenJDK is compatible with SPS-L v9.4.0, therefore customers may use this version or any compatible version of OpenJDK with SPS-L v9.4.0. If a customer encounters an issue due to the OpenJDK version, SIOS may recommend using a newer version of OpenJDK or the OracleJDK included in SPS-L package.

Install The -s option for saving the current setup configuration has been added to the setup command.
RHEL7.6 also does not support DataKeeper’s asynchronous mode. The warning message is output by setup.
DataKeeper

Wait For Previous Source for multi-target mirrors.

For a multi-target mirror DataKeeper keeps track of the last server, aka previous source, that had the mirror in-service. When there is a failover, the bitmap from the previous source is required to keep all of the targets in-sync. DataKeeper will now automatically wait for the previous source to join the cluster before resuming replication to any target. This allows the bitmap from the previous source to be merged so that only partial resyncs are necessary.

Unnecessary synchronization is avoided in the environment with three or mode nodes.
Add updated messages for “wait for source” in GUI and mirror_status.
PostgreSQL PostgreSQL 11 is supported.
EDB Postgres Advanced Server v11 is supported.
FUJITSU Software Enterprise Postgres 10 is supported.
For the details, refer to the SPS Optional Recovery Software Requirements.
MQ SIOS Protection Suite for Linux now supports IBM MQ 9.1
Oracle Support Oracle 19c (Certified in August 2019).
SAP Supports new maintenance mode feature available with SAP kernel 7.49 and above.
General Maintenance Bug Fixes
New in Version 9.3.1
LifeKeeper Core Upgated the OpenSSL package to 1.0.2p
Support Red Hat Enterprise Linux 6.10
Support CentOS 6.10
Support Oracle Linux 6 Update 10
MySQL Support MySQL 8.0
Oracle Support Oracle 18c (Certified in March 2019)
Install, EC2, Route53 Bug Fix
New in Version 9.3
LifeKeeper Core Red Hat Enterprise Linux Version 7.5 is supported.
However, DataKeeper asynchronous mirrors are not supported because of a Linux kernel bug.
CentOS7.5 is supported.
However, DataKeeper asynchronous mirrors are not supported because of a Linux kernel bug.
Oracle Linux Version 7.5 is supported.
However, DataKeeper asynchronous mirrors are not supported because of a Linux kernel bug.
Support VMware vSphere 6.7 (Certified in October 2018)
Bug Fixes
EC2, Route53 EC2 and Route53 RK now support HTTP Proxy.
Bug Fixes
Quorum/Witness Storage QWK is now supported. For details, please click here.
Bug Fixes
Install The SPS for Linux installation process has been upgraded. For details, please click here.
SAP, Oracle, Samba, MQ, Sybase, Filesystem, Generic Application, QSP, SAP MaxDB, DataKeeper Bug Fix
New in Version 9.2.2
EC2,Route53 IAM Role is now supported. Users using EC2, Route53 resources in LifeKeeper for Linux v9.2.1 or earlier should make resources support IAM Role.
Please refer to How to make existing resources support IAM Role for details.
* Openswan Recovery Kit does not support IAM Role. You may use v9.2.1 in case of Cross Region configuration.
DataKeeper Support GUID Partition Table (GPT) to identify protected disks
* The supported disk is SCSI Hard Disk or Xen Virtual Disk(xvd) in case of Linux kernel 2.6.27 or earlier.
PostgreSQL Support PostgreSQL 10
EDB Postgres Advanced Server v10.0 is now supported. (Certified in April 2018)
SAP, NAS, EC2 Bug Fix
New in Version 9.2.1
LifeKeeper Core Support Oracle Linux 7.4
Support CentOS 7.4
Support SUSE Linux Enterprise Server 12 SP3
* The kernel should be updated to 4.4.82-6.9.1 for SUSE Linux Enterprise Server 12 SP3
The Recovery Kit for EC2, Route 53 Recovery Kit, Openswan Recovery Kit can now be installed from the setup menu. Openswan Recovery Kit is supported only when using with Cross Region configuration
Bug Fixes
PostgreSQL Support EDB Postgres Advanced Server 9.6
MQ Support IBM MQ 9.0
New in Version 9.2
LifeKeeper Core Support Red Hat Enterprise Linux 7.4
SNMP trap can be sent to multiple targets
Bug fixes
IP IP resources using real IP(primary IP address configured for NIC) can be created
PostgreSQL Support PostgreSQL 9.6
Support FUJITSU Software Enterprise Postgres 9.6
For the details, refer to the SPS Optional Recovery Software Requirements, PostgreSQL Recovery Kit Administration Guide > Administration.
MQ Support IBM MQ 9.0 (Certified in December 2017)
MD, SAP, SAP MaxDB, Quorum/Witness, Route53, Install Bug fixes
New in Version 9.1.2
LifeKeeper Core SUSE Linux Enterprise Server 12 SP2 is supported.
CentOS7.3 is supported.
Red Hat Enterprise Linux Version 6.9 is supported.
kernel of Oracle Linux Version 7.3 is supported.
Bug fixes
PostgreSQL Support PostgreSQL 9.6
Support FUJITSU Software Enterprise Postgres 9.6
For the details, refer to the SPS Optional Recovery Software Requirements, PostgreSQL Recovery Kit Administration Guide > Administration.
Oracle Oracle 12c R2 is supported.
DB2 DB2 11.1 is supported.
IP, QSP, MySQL, NFS Bug fixes
New in Version 9.1.1
LifeKeeper Core SUSE Linux Enterprise Server 12 SP1 support.
* SLES12.0 is not supported.
* Btrfs is not supported.
Red Hat Enterprise Linux Version 7.3 support.
Oracle Linux Version 7.3 support.
* UEK is not supported.
vSphere 6.5 support.
Bug Fixes
PostgreSQL PostgreSQL 9.5 support EDB Postgres Advanced Server v9.5 support
FUJITSU Software Symfoware Server (Open Interface) V12.2 support
FUJITSU Software Symfoware Server (Postgres) V12.3 support
FUJITSU Software Enterprise Postgres 9.5 support
For the details, refer to the SPS Optional Recovery Software Requirements, PostgreSQL Recovery Kit Administration Guide > Administration.
Sybase ASE Sybase ASE 16.0 support.
MySQL MySQL 5.7 support on RHEL 7.x/CentOS 7.x/OEL 7.x.
* MySQL 5.7 on other OS is already supported.
SAP SAP 7.5 support.
New in Version 9.1.0
LifeKeeper Core Red Hat Enterprise Linux 6.8 support (Certified in September 2016).
CentOS 6.8, Oracle Linux 6.8 support (Certified in September 2016).
* MD RecoveryKit is not supported on these OS.
LifeKeeper API for Monitoring
Added API to supply LifeKeeper status and log information.
Quick Service Protection support
Added functionality to easily protect OS services.
Bug Fixes
New in Version 9.0.2
LifeKeeper Core Support of Red Hat Enterprise Linux Version 7.2.
* SQL RK is not supported when running on RHEL 7.x/CentOS 7.x/OEL 7.x.
Updated OpenSSL package to version to 1.0.1q
Bug Fixes
MQ Added support for Multi-version WebSphere MQ. With this support queue managers for 7.1, 7.5, and 8.x can all be protected on the same cluster node.
Removed the Recovery Kit restriction that only the mqm user could be used for running MQ commands. With this change any user in the mqm group can be used by the Recovery Kit to run MQ commands.
Bug Fixes
IP, Filesystem, DMMP, DataKeeper, EC2, PostgreSQL, Power Path, SAP, SAP DB/MaxDB, Oracle Bug Fixes.
Licensing Update to a newer version of FlexNet
New in Version 9.0.1
LifeKeeper Core Bug Fixes.
DataKeeper Bug Fixes.
New in Version 9.0
LifeKeeper Core Red Hat Enterprise Linux Version 6 Update 7 support. (Certified in October 2015)
Community ENTerprise Operating System (CentOS) Version 6 Update 7 support. (Certified in October 2015)
Oracle Linux Version 6 Update 7 support. (Certified in October 2015)
SUSE LINUX Enterprise Server 11 SP4 support. (Certified in October 2015)
Chef support (2 node Data Replication configuration with IP/FileSystem/Apache/MySQL/PostgreSQL ARKs are supported.)
Added SPS for Linux Parameters List, document detailing tunable values. Added the lkchkconf command.
vSphere 6 support
reiserfs filesystem type is no longer supported.
Arks supported with Red Hat Enterprise Linux Version 7.0/7.1, Community ENTerprise Operating System (CentOS) Version 7.0/7.1, and Oracle Linux Version 7.0/7.1 are the same as LifeKeeper for Linux v8.4.1. (Arks to be supported are: PostgreSQL, MySQL, Oracle, DB2, Apache, Postfix, DMMP, LVM, NFS, NAS, Samba, MD, EC2, Route53, Openswan)
Bug Fixes.
DataKeeper The DK rewind feature is no longer supported in version 9. Prior to upgrading to version 9, you will need to deactivate all rewind configuration settings, and perform any necessary archival of data.
Bug Fixes.
GUI JRE 8u51 support. (JRE 7 is no longer supported.)
Chrome Browser is no longer supported.
Bug Fixes.

Bug Fixes

The following is a list of the latest bug fixes and enhancements.

Bug
Description
7494 Modified LifeKeeper service dependencies to avoid a shutdown failure in a systemd environment
7636 Modified the EC2 route table scenario not to conflict with the OS route information
7663 Fixed the method for obtaining a storage device ID in Azure
7683 Increase nbd I/O request handling speed by increasing nr_requests
7684 Increase default async queue size to 4096
7694 aws_iam_migration script aborts with compilation errors when run
7695 Fixed an issue of the wrong SCSI ID being obtained in certain environments
7698 lksupport now checks which network tools are installed before collecting network information on SLES15
7699 The nbd module is now being installed in the correct location during setup
7700 ext2 file system is now excluded from support
7706 Fixed a issue related to exclusive thread control with Quorum/Witness configuration
7708 Corrected log levels for error messages
7709 Corrected an Oracle DBMS startup parameter added a message
7725 Fixed a re-creation of resources failure due to remaining unnecessary processes when an error occurs during resource creation
7728 Modified install packages required for LifeKeeper operaions on SLES15
7738 Corrected an lklogconfig failed to identify and configure logging
7753 Install fails to reload nbd leading to restore failure when nbd devices did not exist
7756 Updated setup script message to warn when using a kernel that does not support DataKeeper asynchronous mode during installation
7757 An error is displayed when creating a DataKeeper resource in an environment where asynchronous mode is not supported
7758 Fixed SAP RK issues related to LifeKeeper upgrades
7772 A warning message is displayed when Secure Boot is enabled when installing DataKeeper
7791 Increased the amount of SAP RK information collected by lksupport
7796 Fixed a problem with restoring SAP resources
7813 When using DataKeeper with a SLES environment, the number of unnecessary odd number of sectors is not checked

System Requirements

SPS Product Requirements

SPS for Linux is supported on any Linux platform that satisfies the minimum requirements included in the Linux Configuration Table. Also refer to the SPS Support Matrix for supported operating systems, applications and virtualization.

Description
Requirement
Linux Operating System See the Linux Configuration Table for specific operating system information.
Virtual Environments The guest operating system running on the virtual machine must be one of the supported versions listed in the Linux Configuration Table. The following virtual environment is an example where SIOS Protection Suite for Linux is deployed. Please refer to the Support Matrix for detailed versions of supported virtualization environments.

  • KVM

  • Oracle VM Server for x86

  • VMware vSphere v5.5, v6.0, v6.5 and v6.7

  • Amazon EC2

  • Nutanix Acropolis Hypervisor

vSAN configuration is supported for vSphere 6.5 or later except RDM which is not supported by VMWare.

Please refer to SIOS Protection Suite for Linux in VMware ESX Server Virtual Machines, Configuration Guidelines for more detailed configuration requirements and limitations.

Fibre channel SAN and shared SCSI cluster configurations are not supported with SPS for Linux running in a KVM and Oracle VM Server for x86 virtual machine.

Note: Some Amazon EC2 configurations have issues when the Shutdown Strategy is set to “Do not Switchover Resources”. For the detailed information, see Troubleshooting > Known Issues and Restrictions.
Memory The minimum memory requirement for a system supporting SPS is 512 MB. This is the minimum amount required by SPS supported Linux distributions. System memory should be sized for the applications that will be running on the SPS protected system as well. Refer to Application Configuration for further information.
Disk Space The SPS Package Cluster requires the following disk space:

    /opt – approx 100MB (depending on kits installed)

    / – approx 110MB

SPS Optional Recovery Software Requirements

The following table shows the software requirements for the optional SPS recovery software.

See Application Configuration for additional requirements and/or restrictions that may apply to applications under SPS protection.

Product
Requirement(s)
SPS Apache Web Server Recovery Kit Apache Web Server v2.4
SAP Recovery Kit SAP NetWeaver 7.0 including Enhancement Package 1,2 and 3
SAP NetWeaver 7.3 including Enhancement Package 1
SAP NetWeaver 7.4
SAP NetWeaver 7.5
SAP NetWeaver AS for ABAP 7.51 innovation package
SPS SAP MaxDB Recovery Kit SAP MaxDB v7.9

LifeKeeper v6 or later Core Package Cluster
SPS Postfix Recovery Kit Postfix software provided with the supported Linux distributions installed and configured on each server. The same version of Postfix should be installed on each server.

LifeKeeper v6 or later Core Package Cluster
SPS Oracle Recovery Kit Oracle Database Enterprise Edition v11g R2, v12c, v12c R2, v18c and v19c (excluding ASM and pluggable database)

Oracle Database Standard Edition v11g R2 (excluding ASM and pluggable database)

Oracle Database Standard Edition One (SE1) v11g R2 (excluding ASM and pluggable database)

Oracle Database Standard Edition 2 (SE2) v12c, v12c R2, v18c and v19c (excluding ASM and pluggable database)
SPS DB2 Recovery Kit IBM DB2 Universal Database v10.5, v11.1 and v11.5

IBM DB2 Enterprise Server Edition (ESE) v10.5, v11.1 and v11.5

IBM DB2 Workgroup Server Edition (WSE) v10.5, v11.1 and v11.5

IBM DB2 Express Edition v10.5, v11.1 and v11.5

LifeKeeper v6 or later Core Package Cluster

SPS NFS Server Recovery Kit v5.1 or later (for DB2 EEE and DB2 ESE with multiple partitions only)
SPS MySQL Recovery Kit MySQL and MySQL Enterprise v5.7 and v8.0

MariaDB v5.5, v10.0 and v10.3
SPS PostgreSQL Recovery Kit PostgreSQL v9.4, v9.5, v9.6, v10 and v11

EnterpriseDB Postgres Plus Advanced Server v9.4 and v10.0

EDB Postgres Advanced Server v9.5, v9.6 and v10.0

The following edition of FUJITSU Software Symfoware Server.

Symfoware Server V12.2

  • Symfoware Server (Open Interface) V12.2 Enterprise Edition

  • Symfoware Server (Open Interface) V12.2 Standard Edition

Symfoware Server V12.3

  • Symfoware Server (Postgres) V12.3 Enterprise Edition

  • Symfoware Server (Postgres) V12.3 Standard Edition

  • Symfoware Server (Postgres) V12.3 Lite Edition

The following edition of FUJITSU Software Enterprise Postgres 9.5

  • FUJITSU Software Enterprise Postgres 9.5 Advanced Edition

  • FUJITSU Software Enterprise Postgres 9.5 Standard Edition

The following edition of FUJITSU Software Enterprise Postgres 9.6

  • FUJITSU Software Enterprise Postgres 9.6 Standard Edition

The following edition of FUJITSU Software Enterprise Postgres 10

  • FUJITSU Software Enterprise Postgres 10 Advanced Edition

  • FUJITSU Software Enterprise Postgres 10 Standard Edition

  • FUJITSU Software Enterprise Postgres 10 Community Edition
SPS Sybase ASE Recovery Kit Sybase ASE 15.7 and 16.0
SPS Samba Recovery Kit Standard Samba file services provided with the supported Linux distributions
SPS NFS Server Recovery Kit Linux kernel version 2.6 or later

The NFS Server and client packages must be installed on SLES systems.

NFSv2 is not supported on Red Hat Enterprise Linux 7 or later, CentOS 7 or later, Oracle Linux 7 or later.

NFS over UDP is not supported on Red Hat Enterprise Linux 8 and later.

Some environments may require additional configurations. Refer to NFS Specific Configuration Considerations.

SPS Network Attached Storage Recovery Kit NFS version of Mounted NFS file systems from an NFS server or Network Attached Storage (NAS) device v2, v3 and v4
SPS Logical Volume Manager (LVM) Recovery Kit Linux Logical Volume Manager (LVM) Version 1 or 2 volume groups and logical volumes
SPS Software RAID (md) Recovery Kit Software RAID devices based on md

Note: The MD Recovery Kit cannot be used in conjunction with SIOS DataKeeper.
EMC PowerPath PowerPath for Linux v5.3 or later

The sg3_utils Sg3_utils package must be installed.
Device Mapper Multipath (DMMP) The device-mapper-multipath package attached to the operating system.

The sg3_utils package must be installed.
Hitachi Dynamic Link Manager Software (HDLM) Please see Hitachi Dynamic Link Manager Software Multipath I/O Configurations and Linux Distribution Requirements.

The sg3_utils package must be installed.
NEC iStorage Storage Path Savior (NECSPS) iStorage StoragePathSavior for Linux v3.3 or later

For the supported Linux kernel and distribution, please refer to the support information of StoragePathSystem for Linux.

The sg3_utils package must be installed on Red Hat and SLES.

LifeKeeper v6 or later Core Package Cluster
WebSphere MQ Resources IBM MQ v8.0, v9.0 and v9.1.

See Known Issues and Restrictions > Installation.
Quorum/Witness Package All nodes which will participate in a quorum/witness mode cluster, including witness-only nodes, should be installed with the Quorum/Witness Server Support Package for SPS.

Client Platforms and Browsers

The SPS web client can run on any platform that provides support for Java Runtime Environment JRE8 update 51. The currently supported browsers are Firefox (Firefox 51 or earler) and Internet Explorer running on Linux, Windows Server 2008 R2, Windows Server 2012 R2, Windows Server 2016, Windows 7, Windows 8 or Windows 10 with JRE8 update 51. Other recent platforms and browsers will likely work with the SPS web client, but they have not been tested by SIOS Technology Corp. In addition, particular features of each browser have not been tested.

You should specify all the hostnames and addresses in your cluster in the client machine’s local hosts file (usually /etc/hosts or C:\windows\system32\drivers\etc\hosts). This minimizes the client connection time and allows the client to connect even in the event of a Domain Name Server (DNS) failure.

Installation and Configuration

See the SIOS Protection Suite Installation Guide for complete installation and configuration information.

Upgrades

LifeKeeper can be upgraded to Version 9.4.x from either LifeKeeper Version 9.2.x or Version 9.3.x. If upgrading from a version other than 9.2.x or 9.3.x, the older version will need to be uninstalled and SIOS Protection Suite for Linux will have to be reinstalled. An alternative to uninstalling the older version would be to upgrade from the older version to 9.2.x or 9.3.x, then perform the upgrade to 9.4.x.

Storage and Adapter Options

For a list of the disk array storage models and adapters currently supported by SPS in shared storage configurations as well as their type of certification, see the Storage and Adapter Options topic. Details about driver versions and other configuration requirements for these arrays and adapters are listed in the Storage and Adapter Configuration topic.

Technical Notes

We strongly recommend that you read the Technical Notes section concerning configuration and operational issues related to your SPS environment.

Known Issues

See Known Issues and Restrictions in the Troubleshooting section of SIOS Protection Suite for Linux Technical Documentation and the DataKeeper Troubleshooting section.

Feedback

Was this helpful?

Yes No
You indicated this topic was not helpful to you ...
Could you please leave a comment telling us why? Thank you!
Thanks for your feedback.

Post your comment on this topic.

Post Comment