Before attempting to install or remove the SIOS Protection Suite Microsoft IIS Recovery Kit, be sure that your configuration meets the following requirements:

  • Operating System software. SIOS Protection Suite supports the following versions of Windows operating systems:

    • Windows Server 2008 R2 and 2012 Standard, Enterprise, Data Center, Web Editions

  • SIOS Protection Suite software. You must install the same version of SIOS Protection Suite software and any patches on each server. Please refer to the Release Notes for specific requirements.
  • SIOS DataKeeper software (optional). If you plan to use IIS with replicated volumes rather than shared storage, you should install the SIOS DataKeeper for Windows software on each server.
  • SIOS Protection Suite IP Recovery Kit. You must have the SIOS Protection Suite IP Recovery Kit installed on each server. All TCP/IP configuration requirements for the IP Recovery Kit also apply to the SIOS Protection Suite Microsoft IIS Recovery Kit.
  • IP network interface. Each server requires at least one Ethernet TCP/IP-supported network interface. In order for IP switchover to work properly, user systems connected to the local network should conform to standard TCP/IP specifications. Note: Even though each server requires only a single network interface, you should use multiple interfaces for a number of reasons: throughput requirements, elimination of single points of failure,network segmentation, and so forth.
  • TCP/IP protocol. Each server requires TCP/IP to be installed and configured properly.

    • The two servers must be on the same LAN segment (that is, no routers between the two systems).

    • Free IP addresses to create SIOS Protection Suite hierarchies:

      • For each active Microsoft IIS site, you will need one switchable IP address to be shared between the active and standby IIS site.

      • If you plan to protect multiple Microsoft IIS sites, you will need additional IP addresses for each protected IIS resource.

    • IIS Software. The IIS Recovery Kit supports Microsoft Internet Information Services (IIS), Release 5.0, Release 6.0, Release 7.0, and Release 7.5. For systems running the IIS Kit and Microsoft FTP Service 7.5, Windows 2008 R2 is required. Microsoft FTP 7.5 service ships as a feature (Identified as “FTP Service”) in Windows 7 and Windows Server 2008 R2.

Note: The IIS Recovery Kit does not support Microsoft FTP Service 7.5 if installed manually out-of-band on Windows 2008 R1.

Microsoft IIS software, IIS server roles, FTP feature or SMTP feature must be installed and configured prior to configuring SIOS Protection Suite and the SIOS Protection Suite Microsoft IIS Recovery Kit. The same version should be installed on each server. Please refer to IIS Required Roles and Role Services and Features for requirements that must be installed on each server.

Feedback

Was this helpful?

Yes No
You indicated this topic was not helpful to you ...
Could you please leave a comment telling us why? Thank you!
Thanks for your feedback.

Post your comment on this topic.

Post Comment