You are here: Installation > RPM Installation

RPM Installation

The first step in configuring SAP with LifeKeeper is to install the RPM module.

If installing for the first time, use the Linux rpm install to install the module:

rpm -i steeleye-lkSAP-(Version).noarch.rpm

However, for an update from a previous release, perform the following command:

rpm -Uvh steeleye-lkSAP-(Version).noarch.rpm 

The rpm module does certain checking and might fail if the environment is not set up correctly as shown in this example:

SAP Services file /usr/sap/sapservices not found

SAP Installation is not valid; please check environment and retry

error: %pre(steeleye-lkSAP-7.3.1-1.noarch) scriptlet failed, exit status 2

error:   install: %pre scriptlet failed (2), skipping steeleye-lkSAP-7.3.1-1

In the above example, the expected SAP file, /usr/sap/sapservices, is missing. It is very important for the environment to be in the right state before installation can continue.

Note: If running a version prior to SAP Netweaver 7.3, the SAPHOST agent will need to be installed. See the Important Note in the Plan Your Configuration topic for more information. 

Once the rpm module is installed, proceed with Resource Configuration Tasks.

© 2012 SIOS Technology Corp., the industry's leading provider of business continuity solutions, data replication for continuous data protection.